summaryrefslogtreecommitdiffstats
path: root/ext/ladspa/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2005-08-25 09:30:24 +0000
committerAndy Wingo <wingo@pobox.com>2005-08-25 09:30:24 +0000
commit0582ab12916859fdc3815010e68aafb131c9570c (patch)
tree2284e326926c95feed4e5b849acf1f4b3485f604 /ext/ladspa/Makefile.am
parent38d8867a0f70785789dbf469d8d4129a45517a95 (diff)
ext/ladspa/gstladspa.*: Halfway-ported. Doesn't compile yet.
Original commit message from CVS: 2005-08-25 Andy Wingo <wingo@pobox.com> * ext/ladspa/gstladspa.h: * ext/ladspa/gstladspa.c: Halfway-ported. Doesn't compile yet. * ext/ladspa/gstsignalprocessor.h: * ext/ladspa/gstsignalprocessor.c: New files, the start of a base class for DSP elements. * configure.ac: Sort the external libs checks, add a ladspa check, output the ladspa makefile.
Diffstat (limited to 'ext/ladspa/Makefile.am')
-rw-r--r--ext/ladspa/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/ext/ladspa/Makefile.am b/ext/ladspa/Makefile.am
index c7c654fd..ce5302d5 100644
--- a/ext/ladspa/Makefile.am
+++ b/ext/ladspa/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstladspa.la
-libgstladspa_la_SOURCES = gstladspa.c search.c load.c
-libgstladspa_la_CFLAGS = $(GST_CFLAGS)
-libgstladspa_la_LIBADD = $(GST_LIBS)
+libgstladspa_la_SOURCES = gstsignalprocessor.c gstladspa.c search.c load.c
+libgstladspa_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstladspa_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@
libgstladspa_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstladspa.h utils.h
+noinst_HEADERS = gstsignalprocessor.h gstladspa.h utils.h