summaryrefslogtreecommitdiffstats
path: root/ext/speex/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2002-12-16 19:49:42 +0000
committerWim Taymans <wim.taymans@gmail.com>2002-12-16 19:49:42 +0000
commita50b19e9216dbbf9c76569bdde171f550d476db8 (patch)
treed5c78b9dc1e7a60f5e4d4653afa7f96bd043d7f0 /ext/speex/Makefile.am
parent7fa045ebaa42abdd276dd1e63159fad7e1202636 (diff)
Added non functional speex plugin. speex decoding needs a container.
Original commit message from CVS: Added non functional speex plugin. speex decoding needs a container.
Diffstat (limited to 'ext/speex/Makefile.am')
-rw-r--r--ext/speex/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ext/speex/Makefile.am b/ext/speex/Makefile.am
new file mode 100644
index 00000000..7d0a65f0
--- /dev/null
+++ b/ext/speex/Makefile.am
@@ -0,0 +1,10 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstspeex.la
+
+libgstspeex_la_SOURCES = gstspeex.c gstspeexdec.c gstspeexenc.c
+libgstspeex_la_CFLAGS = $(GST_CFLAGS)
+libgstspeex_la_LIBADD = -lspeex
+libgstspeex_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstspeexenc.h gstspeexdec.h