summaryrefslogtreecommitdiffstats
path: root/ext/taglib/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-05-01 11:46:33 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-05-01 11:46:33 +0000
commit8d58b030d62888b25efa032fb7dba368730704b0 (patch)
tree300f444b9e9210ab3ccf2ef40d4447f0c7b2ade4 /ext/taglib/Makefile.am
parenta4ddb7b60a7a0750de0b80a47d6cbe1b41b71f3a (diff)
docs/plugins/Makefile.am: also check .cc files for gtk-doc markup
Original commit message from CVS: * docs/plugins/Makefile.am: also check .cc files for gtk-doc markup * configure.ac: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * tests/check/Makefile.am: * tests/check/elements/id3v2mux.c: (id3v2mux_suite), (main): * ext/Makefile.am: * ext/taglib/Makefile.am: * ext/taglib/gstid3v2mux.h: * ext/taglib/gsttaglibmux.c: * ext/taglib/gsttaglibmux.h: move taglib-based id3v2muxer to -good. Fixes #336110.
Diffstat (limited to 'ext/taglib/Makefile.am')
-rw-r--r--ext/taglib/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/ext/taglib/Makefile.am b/ext/taglib/Makefile.am
index 0b608f3d..e1ffd5cd 100644
--- a/ext/taglib/Makefile.am
+++ b/ext/taglib/Makefile.am
@@ -1,6 +1,10 @@
plugin_LTLIBRARIES = libgsttaglib.la
-libgsttaglib_la_SOURCES = gsttaglib.cc gstid3v2mux.cc
+libgsttaglib_la_SOURCES = gsttaglibmux.c gstid3v2mux.cc
+libgsttaglib_la_CFLAGS = \
+ $(GST_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(TAGLIB_CFLAGS)
libgsttaglib_la_CXXFLAGS = \
$(GST_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS) \
@@ -11,6 +15,4 @@ libgsttaglib_la_LIBADD = \
$(TAGLIB_LIBS)
libgsttaglib_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gsttaglib.h gstid3v2mux.h
-
-#EXTRA_DIST = README
+noinst_HEADERS = gsttaglibmux.h gstid3v2mux.h