summaryrefslogtreecommitdiffstats
path: root/ext/wavpack/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2006-07-18 14:08:06 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-07-18 14:08:06 +0000
commit72bc1ba4ba1d799bf0439f834ef77f8a582a2929 (patch)
treea3bdf7f7ac002c0b890bc37b77425c5c97e12ce4 /ext/wavpack/Makefile.am
parentae5b12066bfe842dcf8125c34172d302d7398662 (diff)
configure.ac: Check for wavpack version and define WAVPACK_OLD_API if necessary.
Original commit message from CVS: Patch by: Sebastian Dröge <slomo at circular-chaos.org> * configure.ac: Check for wavpack version and define WAVPACK_OLD_API if necessary. * ext/wavpack/Makefile.am: * ext/wavpack/gstwavpackcommon.c: (gst_wavpack_read_header), (gst_wavpack_read_metadata): * ext/wavpack/gstwavpackcommon.h: * ext/wavpack/gstwavpackdec.c: (gst_wavpack_dec_base_init), (gst_wavpack_dec_class_init), (gst_wavpack_dec_init), (gst_wavpack_dec_finalize), (gst_wavpack_dec_format_samples), (gst_wavpack_dec_clip_outgoing_buffer), (gst_wavpack_dec_chain), (gst_wavpack_dec_sink_event), (gst_wavpack_dec_change_state), (gst_wavpack_dec_request_new_pad), (gst_wavpack_dec_plugin_init): * ext/wavpack/gstwavpackdec.h: * ext/wavpack/gstwavpackenc.c: (gst_wavpack_enc_class_init), (gst_wavpack_enc_init), (gst_wavpack_enc_finalize), (gst_wavpack_enc_set_wp_config): * ext/wavpack/gstwavpackparse.c: (gst_wavpack_parse_base_init), (gst_wavpack_parse_finalize), (gst_wavpack_parse_class_init), (gst_wavpack_parse_index_get_entry_from_sample), (gst_wavpack_parse_scan_to_find_sample), (gst_wavpack_parse_handle_seek_event), (gst_wavpack_parse_create_src_pad): * ext/wavpack/gstwavpackstreamreader.c: * ext/wavpack/gstwavpackstreamreader.h: Port to new/official wavpack API, don't use API that was exported in wavpack header files and in the lib but meant to be private, at least not for recent wavpack versions; misc. 'cleanups' (#347443).
Diffstat (limited to 'ext/wavpack/Makefile.am')
-rw-r--r--ext/wavpack/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/ext/wavpack/Makefile.am b/ext/wavpack/Makefile.am
index 9220fd78..241e4dcf 100644
--- a/ext/wavpack/Makefile.am
+++ b/ext/wavpack/Makefile.am
@@ -7,10 +7,11 @@ libgstwavpack_la_SOURCES = \
gstwavpackparse.c \
gstwavpackdec.c \
gstwavpackenc.c \
+ gstwavpackstreamreader.c \
md5.c
-libgstwavpack_la_CFLAGS = $(GST_CFLAGS) $(WAVPACK_CFLAGS)
-libgstwavpack_la_LIBADD = $(GST_LIBS) $(WAVPACK_LIBS)
+libgstwavpack_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(WAVPACK_CFLAGS)
+libgstwavpack_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(WAVPACK_LIBS)
libgstwavpack_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
@@ -18,5 +19,6 @@ noinst_HEADERS = \
gstwavpackdec.h \
gstwavpackenc.h \
gstwavpackcommon.h \
+ gstwavpackstreamreader.h \
md5.h