summaryrefslogtreecommitdiffstats
path: root/gst/audiofx/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2008-05-26 15:51:41 +0000
committerWim Taymans <wim.taymans@gmail.com>2008-05-26 15:51:41 +0000
commit0007831a6e684f56222972eeb9f13379e35289c0 (patch)
treead3e9960547e7988850129b6b5a5e5fc8dec7cb5 /gst/audiofx/Makefile.am
parent61597d99e9a1ef19862e7b222500504f644e4c12 (diff)
gst/audiofx/: Add simple voice removal element. Yay karaoke.
Original commit message from CVS: * gst/audiofx/Makefile.am: * gst/audiofx/audiofx.c: (plugin_init): * gst/audiofx/audiovoice.c: (gst_audio_voice_base_init), (gst_audio_voice_class_init), (gst_audio_voice_init), (update_filter), (gst_audio_voice_set_property), (gst_audio_voice_get_property), (gst_audio_voice_setup), (gst_audio_voice_transform_int), (gst_audio_voice_transform_float), (gst_audio_voice_transform_ip): * gst/audiofx/audiovoice.h: Add simple voice removal element. Yay karaoke.
Diffstat (limited to 'gst/audiofx/Makefile.am')
-rw-r--r--gst/audiofx/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gst/audiofx/Makefile.am b/gst/audiofx/Makefile.am
index 3c0df213..28de5e2a 100644
--- a/gst/audiofx/Makefile.am
+++ b/gst/audiofx/Makefile.am
@@ -8,6 +8,7 @@ libgstaudiofx_la_SOURCES = audiofx.c\
audioinvert.c \
audioamplify.c \
audiodynamic.c \
+ audiovoice.c \
audiocheblimit.c \
audiochebband.c \
audiowsincband.c \
@@ -31,6 +32,7 @@ noinst_HEADERS = audiopanorama.h \
audioinvert.h \
audioamplify.h \
audiodynamic.h \
+ audiovoice.h \
audiocheblimit.h \
audiochebband.h \
audiowsincband.h \