summaryrefslogtreecommitdiffstats
path: root/gst/audiofx/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2006-08-21 09:21:27 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2006-08-21 09:21:27 +0000
commit1f46af88e2af63b1d8890c606f48ab0dc9b116b5 (patch)
tree67002120d88f98edb971d63ce71caabf55e54d66 /gst/audiofx/Makefile.am
parentf9dd03ca3b7e2a66df16b96fd7c1b0d89c6a4250 (diff)
gst/audiofxgood/: resubmit with the desired name *again*
Original commit message from CVS: * gst/audiofxgood/.cvsignore: * gst/audiofxgood/Makefile.am: * gst/audiofxgood/audiofx.c: (plugin_init): * gst/audiofxgood/audiopanorama.c: (gst_audio_panorama_base_init), (gst_audio_panorama_class_init), (gst_audio_panorama_init), (gst_audio_panorama_set_property), (gst_audio_panorama_get_property), (gst_audio_panorama_get_unit_size), (gst_audio_panorama_transform_caps), (gst_audio_panorama_set_caps), (gst_audio_panorama_transform_m2s), (gst_audio_panorama_transform_s2s), (gst_audio_panorama_transform): * gst/audiofxgood/audiopanorama.h: resubmit with the desired name *again*
Diffstat (limited to 'gst/audiofx/Makefile.am')
-rw-r--r--gst/audiofx/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/gst/audiofx/Makefile.am b/gst/audiofx/Makefile.am
new file mode 100644
index 00000000..34708cfe
--- /dev/null
+++ b/gst/audiofx/Makefile.am
@@ -0,0 +1,19 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstaudiofxgood.la
+
+# sources used to compile this plug-in
+libgstaudiofxgood_la_SOURCES = audiofx.c\
+ audiopanorama.c
+
+# flags used to compile this plugin
+libgstaudiofxgood_la_CFLAGS = $(GST_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CONTROLLER_CFLAGS)
+libgstaudiofxgood_la_LIBADD = $(GST_LIBS) \
+ $(GST_BASE_LIBS) \
+ $(GST_CONTROLLER_LIBS)
+libgstaudiofxgood_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = audiopanorama.h