summaryrefslogtreecommitdiffstats
path: root/gst/audiofx/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2007-02-06 11:16:49 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2007-02-06 11:16:49 +0000
commitcdba2c4219705c69fffb7bc5c08bc1ffdd3a75b4 (patch)
tree7f78af050fcee5f41fec0cb8ec4872d0926fed97 /gst/audiofx/Makefile.am
parentf7935f9a40fa99ef1cb40735688ccd1ad936702d (diff)
gst/audiofx/: Some small cleanups and port both elements to the new GstAudioFilter base class to save a few lines of ...
Original commit message from CVS: * gst/audiofx/audioamplify.c: (gst_audio_amplify_base_init), (gst_audio_amplify_class_init), (gst_audio_amplify_init), (gst_audio_amplify_set_process_function), (gst_audio_amplify_setup): * gst/audiofx/audioamplify.h: * gst/audiofx/audioinvert.c: (gst_audio_invert_base_init), (gst_audio_invert_class_init), (gst_audio_invert_setup): * gst/audiofx/audioinvert.h: Some small cleanups and port both elements to the new GstAudioFilter base class to save a few lines of common code. * gst/audiofx/Makefile.am: Link against libgstaudio for the above changes
Diffstat (limited to 'gst/audiofx/Makefile.am')
-rw-r--r--gst/audiofx/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/gst/audiofx/Makefile.am b/gst/audiofx/Makefile.am
index b3ac0b1a..cb2a180e 100644
--- a/gst/audiofx/Makefile.am
+++ b/gst/audiofx/Makefile.am
@@ -11,10 +11,13 @@ libgstaudiofx_la_SOURCES = audiofx.c\
# flags used to compile this plugin
libgstaudiofx_la_CFLAGS = $(GST_CFLAGS) \
$(GST_BASE_CFLAGS) \
- $(GST_CONTROLLER_CFLAGS)
+ $(GST_CONTROLLER_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
libgstaudiofx_la_LIBADD = $(GST_LIBS) \
$(GST_BASE_LIBS) \
- $(GST_CONTROLLER_LIBS)
+ $(GST_CONTROLLER_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-$(GST_MAJORMINOR)
libgstaudiofx_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
# headers we need but don't want installed