summaryrefslogtreecommitdiffstats
path: root/gst/flv/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-10-27 09:41:18 +0000
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-05-12 21:20:59 +0200
commita023bf6f92fb3555fcf683624bf72f2770052899 (patch)
tree2cb284fa9bfb0946c81ec1b463674b3caaea1700 /gst/flv/Makefile.am
parentab136d52ebb969f03b63543846db5858ba0161df (diff)
[MOVED FROM BAD 42/57] gst/flv/Makefile.am: Fix (non-critical) syntax error and add all required CFLAGS and LIBS.
Original commit message from CVS: * gst/flv/Makefile.am: Fix (non-critical) syntax error and add all required CFLAGS and LIBS. * gst/flv/gstflvparse.c: (FLV_GET_STRING), (gst_flv_parse_metadata_item), (gst_flv_parse_tag_script), (gst_flv_parse_tag_audio), (gst_flv_parse_tag_video), (gst_flv_parse_tag_timestamp), (gst_flv_parse_tag_type): Rewrite the script tag parsing to make sure we don't try to read more data than we have. Also use GST_READ_UINT24_BE directly and fix some minor memory leaks. This should make all crashes on fuzzed FLV files disappear.
Diffstat (limited to 'gst/flv/Makefile.am')
-rw-r--r--gst/flv/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/flv/Makefile.am b/gst/flv/Makefile.am
index 08018d20..0b8d469c 100644
--- a/gst/flv/Makefile.am
+++ b/gst/flv/Makefile.am
@@ -1,7 +1,7 @@
plugin_LTLIBRARIES = libgstflv.la
-libgstflv_la_CFLAGS = ${GST_CFLAGS}
-libgstflv_la_LIBADD = $(GST_BASE_LIBS)
+libgstflv_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstflv_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
libgstflv_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
libgstflv_la_SOURCES = gstflvdemux.c gstflvparse.c gstflvmux.c