summaryrefslogtreecommitdiffstats
path: root/gst/interleave/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-05-16 21:56:24 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-05-16 21:56:24 +0000
commit8c254cffdc2ac425fd807c563fab7634ccffaf82 (patch)
tree6301b592703c7f70ca72f9e94f305d89036c3f1e /gst/interleave/Makefile.am
parente9370329dd317230bb2832b2f5f73434f2074e87 (diff)
gst/interleave/: Add support for all raw audio formats and provide better negotiation if the caps are changing.
Original commit message from CVS: * gst/interleave/Makefile.am: * gst/interleave/deinterleave.c: (deinterleave_24), (gst_deinterleave_finalize), (gst_deinterleave_base_init), (gst_deinterleave_class_init), (gst_deinterleave_init), (gst_deinterleave_add_new_pads), (gst_deinterleave_set_pads_caps), (gst_deinterleave_set_process_function), (gst_deinterleave_sink_setcaps), (__remove_channels), (__set_channels), (gst_deinterleave_getcaps), (gst_deinterleave_process), (gst_deinterleave_chain), (gst_deinterleave_sink_activate_push): * gst/interleave/deinterleave.h: Add support for all raw audio formats and provide better negotiation if the caps are changing. Don't allow changes of the channel positions and set the position of the corresponding channel on the src pad caps. General cleanup and smaller bugfixes. * tests/check/elements/deinterleave.c: (float_buffer_check_probe): Check the channel positions on the output buffer caps.
Diffstat (limited to 'gst/interleave/Makefile.am')
-rw-r--r--gst/interleave/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/interleave/Makefile.am b/gst/interleave/Makefile.am
index 62e7f3e3..3477933c 100644
--- a/gst/interleave/Makefile.am
+++ b/gst/interleave/Makefile.am
@@ -2,8 +2,8 @@
plugin_LTLIBRARIES = libgstinterleave.la
libgstinterleave_la_SOURCES = plugin.c interleave.c deinterleave.c
-libgstinterleave_la_CFLAGS = $(GST_CFLAGS)
-libgstinterleave_la_LIBADD = $(GST_LIBS)
+libgstinterleave_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstinterleave_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR)
libgstinterleave_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = plugin.h interleave.h deinterleave.h