summaryrefslogtreecommitdiffstats
path: root/gst/qtdemux/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-01-05 18:32:03 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-05 18:32:03 +0000
commit9445ca84f5bd8b62278c1729df60cb33440c36d5 (patch)
treec4a2f92936e0b1c3db885c86da9af013230f8b78 /gst/qtdemux/Makefile.am
parent5d78ae0a1c34b888b87ae64f7e188860816c7e06 (diff)
Check for zlib and if available pass it explicitly to the linker when linking qtdemux. If not available (or --disable...
Original commit message from CVS: * configure.ac: * gst/qtdemux/Makefile.am: * gst/qtdemux/qtdemux.c: (qtdemux_parse_moov): Check for zlib and if available pass it explicitly to the linker when linking qtdemux. If not available (or --disable-external has been specified!), disable the bits in qtdemux that use it. Fixes build on MingW (#392856).
Diffstat (limited to 'gst/qtdemux/Makefile.am')
-rw-r--r--gst/qtdemux/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gst/qtdemux/Makefile.am b/gst/qtdemux/Makefile.am
index f65f337e..1f480365 100644
--- a/gst/qtdemux/Makefile.am
+++ b/gst/qtdemux/Makefile.am
@@ -2,7 +2,7 @@
plugin_LTLIBRARIES = libgstqtdemux.la
libgstqtdemux_la_CFLAGS = ${GST_CFLAGS}
-libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS)
+libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS) $(ZLIB_LIBS)
libgstqtdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
libgstqtdemux_la_SOURCES = qtdemux.c