summaryrefslogtreecommitdiffstats
path: root/gst/rtp/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2007-01-24 18:20:14 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-01-24 18:20:14 +0000
commit85420195b22b54f306833be2d4ba66fd2ff6b6e8 (patch)
treea6100c8b69d0291ae4e2e694121b34cab2fc37a0 /gst/rtp/Makefile.am
parenta6a9207c4298081d2af237edd04e337e5d175e0d (diff)
gst/rtp/: Port and enable raw audio payloader/depayloader. Needs a bit more work on the payloader side.
Original commit message from CVS: * gst/rtp/Makefile.am: * gst/rtp/gstrtp.c: (plugin_init): * gst/rtp/gstrtpL16depay.c: (gst_rtp_L16_depay_base_init), (gst_rtp_L16_depay_class_init), (gst_rtp_L16_depay_init), (gst_rtp_L16_depay_parse_int), (gst_rtp_L16_depay_setcaps), (gst_rtp_L16_depay_process), (gst_rtp_L16_depay_set_property), (gst_rtp_L16_depay_get_property), (gst_rtp_L16_depay_change_state), (gst_rtp_L16_depay_plugin_init): * gst/rtp/gstrtpL16depay.h: * gst/rtp/gstrtpL16pay.c: (gst_rtp_L16_pay_get_type), (gst_rtp_L16_pay_base_init), (gst_rtp_L16_pay_class_init), (gst_rtp_L16_pay_init), (gst_rtp_L16_pay_finalize), (gst_rtp_L16_pay_setcaps), (gst_rtp_L16_pay_handle_buffer), (gst_rtp_L16_pay_plugin_init): * gst/rtp/gstrtpL16pay.h: Port and enable raw audio payloader/depayloader. Needs a bit more work on the payloader side.
Diffstat (limited to 'gst/rtp/Makefile.am')
-rw-r--r--gst/rtp/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/rtp/Makefile.am b/gst/rtp/Makefile.am
index 1273800c..284d0547 100644
--- a/gst/rtp/Makefile.am
+++ b/gst/rtp/Makefile.am
@@ -21,6 +21,8 @@ libgstrtp_la_SOURCES = \
gstrtph263ppay.c \
gstrtph263pay.c \
gstrtph264depay.c \
+ gstrtpL16depay.c \
+ gstrtpL16pay.c \
gstasteriskh263.c \
gstrtpmp2tdepay.c \
gstrtpmp4vdepay.c \
@@ -35,7 +37,6 @@ libgstrtp_la_SOURCES = \
gstrtpvorbisdepay.c \
gstrtpvorbispay.c
-#gstrtpL16pay.c gstrtpL16depay.c
if HAVE_WINSOCK2_H
WINSOCK2_LIBS = -lws2_32