summaryrefslogtreecommitdiffstats
path: root/gst/rtp/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sf.net>2007-03-28 18:40:12 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-03-28 18:40:12 +0000
commitc0cdcae569856ad5faa847294631c9219bd07799 (patch)
tree732ea8035075241ed5b9a3c047fda434b83e5e7a /gst/rtp/Makefile.am
parentab589bff3e975300c0f9f26b534078155c1989ea (diff)
gst/rtp/: Added MP4A-LATM depayloader. Fixes #417792.
Original commit message from CVS: Based on patch by: Stefan Kost <ensonic@users.sf.net> * gst/rtp/Makefile.am: * gst/rtp/gstrtp.c: (plugin_init): * gst/rtp/gstrtpmp4adepay.c: (gst_rtp_mp4a_depay_base_init), (gst_rtp_mp4a_depay_class_init), (gst_rtp_mp4a_depay_init), (gst_rtp_mp4a_depay_finalize), (gst_rtp_mp4a_depay_setcaps), (gst_rtp_mp4a_depay_process), (gst_rtp_mp4a_depay_set_property), (gst_rtp_mp4a_depay_get_property), (gst_rtp_mp4a_depay_change_state), (gst_rtp_mp4a_depay_plugin_init): * gst/rtp/gstrtpmp4adepay.h: Added MP4A-LATM depayloader. Fixes #417792. * gst/rtp/gstrtpmp4vdepay.c: (gst_rtp_mp4v_depay_setcaps), (gst_rtp_mp4v_depay_process): Fixup depayloader, setting codec_data, using more efficient adaptor and rtpbuffer handling. * gst/rtsp/URLS: Add url to test above.
Diffstat (limited to 'gst/rtp/Makefile.am')
-rw-r--r--gst/rtp/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/gst/rtp/Makefile.am b/gst/rtp/Makefile.am
index eec921cb..fb4c87fc 100644
--- a/gst/rtp/Makefile.am
+++ b/gst/rtp/Makefile.am
@@ -21,8 +21,8 @@ libgstrtp_la_SOURCES = \
gstrtph263ppay.c \
gstrtph263pay.c \
gstrtph264depay.c \
- gstrtpL16depay.c \
- gstrtpL16pay.c \
+ gstrtpL16depay.c \
+ gstrtpL16pay.c \
gstasteriskh263.c \
gstrtpmp2tdepay.c \
gstrtpmp2tpay.c \
@@ -30,6 +30,7 @@ libgstrtp_la_SOURCES = \
gstrtpmp4vpay.c \
gstrtpmp4gdepay.c \
gstrtpmp4gpay.c \
+ gstrtpmp4adepay.c \
gstrtpspeexdepay.c \
gstrtpspeexpay.c \
gstrtpsv3vdepay.c \
@@ -54,11 +55,11 @@ libgstrtp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
gstrtpL16depay.h \
gstrtpL16pay.h \
- gstrtpac3depay.h \
+ gstrtpac3depay.h \
gstrtpamrdepay.h \
gstrtpamrpay.h \
gstrtpilbcdepay.h \
- gstrtpilbcpay.h \
+ gstrtpilbcpay.h \
gstrtppcmadepay.h \
gstrtppcmudepay.h \
gstrtppcmupay.h \
@@ -78,6 +79,7 @@ noinst_HEADERS = \
gstrtpmp4vpay.h \
gstrtpmp4gdepay.h \
gstrtpmp4gpay.h \
+ gstrtpmp4adepay.h \
gstrtpdepay.h \
gstasteriskh263.h \
gstrtpspeexdepay.h \