summaryrefslogtreecommitdiffstats
path: root/gst/rtp/Makefile.am
diff options
context:
space:
mode:
authorOlivier Crete <tester@tester.ca>2008-05-13 08:35:55 +0000
committerWim Taymans <wim.taymans@gmail.com>2008-05-13 08:35:55 +0000
commitd6f37dadb51554507a00e91012553a9d8fc98dcc (patch)
treefc43f6ad6e233284314df9b1833a0504684a6648 /gst/rtp/Makefile.am
parentaa959152d139a609371b40b9b2fd39cee16cf942 (diff)
gst/rtp/: Added G729 pay and depayloaders. Fixes #532409.
Original commit message from CVS: Based on patch by: Olivier Crete <tester at tester dot ca> * gst/rtp/Makefile.am: * gst/rtp/gstrtp.c: (plugin_init): * gst/rtp/gstrtpg729depay.c: (gst_rtp_g729_depay_base_init), (gst_rtp_g729_depay_class_init), (gst_rtp_g729_depay_init), (gst_rtp_g729_depay_setcaps), (gst_rtp_g729_depay_process), (gst_rtp_g729_depay_plugin_init): * gst/rtp/gstrtpg729depay.h: * gst/rtp/gstrtpg729pay.c: (gst_rtpg729pay_base_init), (gst_rtpg729pay_class_init), (gst_rtpg729pay_init), (gst_rtpg729pay_setcaps), (gst_rtp_g729_pay_plugin_init): * gst/rtp/gstrtpg729pay.h: Added G729 pay and depayloaders. Fixes #532409.
Diffstat (limited to 'gst/rtp/Makefile.am')
-rw-r--r--gst/rtp/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gst/rtp/Makefile.am b/gst/rtp/Makefile.am
index a797f2b9..c6ab8741 100644
--- a/gst/rtp/Makefile.am
+++ b/gst/rtp/Makefile.am
@@ -17,6 +17,8 @@ libgstrtp_la_SOURCES = \
gstrtppcmudepay.c \
gstrtppcmupay.c \
gstrtppcmapay.c \
+ gstrtpg729pay.c \
+ gstrtpg729depay.c \
gstrtpgsmdepay.c \
gstrtpgsmpay.c \
gstrtpamrdepay.c \
@@ -73,6 +75,8 @@ noinst_HEADERS = \
gstrtppcmudepay.h \
gstrtppcmupay.h \
gstrtppcmapay.h \
+ gstrtpg729depay.h \
+ gstrtpg729pay.h \
gstrtpgsmdepay.h \
gstrtpgsmpay.h \
gstrtpmpadepay.h \