summaryrefslogtreecommitdiffstats
path: root/gst/rtpmanager/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-05-16 19:56:30 +0000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-08-11 02:30:35 +0100
commit4e5347c8feb5583ed3d806a7d51a20ab2b1da05a (patch)
tree40e5f809fa2b6775d511ef2773dee9ee8a0e3ef9 /gst/rtpmanager/Makefile.am
parent2506d13ecc0799000634e7190a4ff526b7ab5980 (diff)
docs/Makefile.am: Don't attempt to build plugin docs when they're disabled.
Original commit message from CVS: * docs/Makefile.am: Don't attempt to build plugin docs when they're disabled. * gst/bayer/Makefile.am: Add libgstvideo to the link. * gst/rtpmanager/Makefile.am: Fix link order, and move LIBS things to _LIBS
Diffstat (limited to 'gst/rtpmanager/Makefile.am')
-rw-r--r--gst/rtpmanager/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/gst/rtpmanager/Makefile.am b/gst/rtpmanager/Makefile.am
index cad27a36..8f214de7 100644
--- a/gst/rtpmanager/Makefile.am
+++ b/gst/rtpmanager/Makefile.am
@@ -36,10 +36,12 @@ noinst_HEADERS = gstrtpbin.h \
rtpstats.h \
gstrtpsession.h
-libgstrtpmanager_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(ERROR_CFLAGS)
-libgstrtpmanager_la_LIBADD = $(GST_LIBS_LIBS)
-libgstrtpmanager_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstrtp-@GST_MAJORMINOR@ \
- -lgstnetbuffer-@GST_MAJORMINOR@
+libgstrtpmanager_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
+ $(ERROR_CFLAGS)
+libgstrtpmanager_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
+ -lgstnetbuffer-@GST_MAJORMINOR@ -lgstrtp-@GST_MAJORMINOR@ \
+ $(GST_BASE_LIBS) $(GST_LIBS_LIBS)
+libgstrtpmanager_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
CLEANFILES = $(BUILT_SOURCES)