summaryrefslogtreecommitdiffstats
path: root/gst/rtpmanager/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2007-04-10 09:14:07 +0000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-08-11 02:30:24 +0100
commit8c67b5d7dd1457aa0bafc89fbd022a0a6d79088c (patch)
treed362f0d634d23ba35d60c103ad7bac634308eec5 /gst/rtpmanager/Makefile.am
parenta6aa41dc2118c811a5e84246722e8c6e99114c32 (diff)
gst/rtpmanager/: Added custom marshallers for signals.
Original commit message from CVS: * gst/rtpmanager/.cvsignore: * gst/rtpmanager/Makefile.am: * gst/rtpmanager/gstrtpbin-marshal.list: Added custom marshallers for signals. * gst/rtpmanager/gstrtpbin.c: (gst_rtp_bin_class_init): * gst/rtpmanager/gstrtpbin.h: Prepare for emiting pt map signals. * gst/rtpmanager/gstrtpptdemux.c: (gst_rtp_pt_demux_class_init): * gst/rtpmanager/gstrtpssrcdemux.c: (gst_rtp_ssrc_demux_class_init): Fix signals.
Diffstat (limited to 'gst/rtpmanager/Makefile.am')
-rw-r--r--gst/rtpmanager/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/gst/rtpmanager/Makefile.am b/gst/rtpmanager/Makefile.am
index dc7f2a72..f844e47c 100644
--- a/gst/rtpmanager/Makefile.am
+++ b/gst/rtpmanager/Makefile.am
@@ -1,6 +1,15 @@
-
plugin_LTLIBRARIES = libgstrtpmanager.la
+glib_enum_define = GST_RTP_BIN
+glib_enum_prefix = gst_rtp_bin
+
+include $(top_srcdir)/common/glib-gen.mak
+
+built_sources = gstrtpbin-marshal.c
+built_headers = gstrtpbin-marshal.h
+
+BUILT_SOURCES = $(built_sources) $(built_headers)
+
libgstrtpmanager_la_SOURCES = gstrtpmanager.c \
gstrtpbin.c \
gstrtpclient.c \
@@ -10,6 +19,9 @@ libgstrtpmanager_la_SOURCES = gstrtpmanager.c \
gstrtpssrcdemux.c \
gstrtpsession.c
+nodist_libgstrtpmanager_la_SOURCES = \
+ $(built_sources)
+
noinst_HEADERS = gstrtpbin.h \
gstrtpclient.h \
async_jitter_queue.h \
@@ -22,5 +34,8 @@ libgstrtpmanager_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(ERROR_CF
libgstrtpmanager_la_LIBADD = $(GST_LIBS_LIBS)
libgstrtpmanager_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstrtp-@GST_MAJORMINOR@
-EXTRA_DIST =
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = gstrtpbin-marshal.list
+