summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2007-06-08 17:37:02 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-06-08 17:37:02 +0000
commit853a9f7fe9956bf6afe10694bdb3def96cf046b7 (patch)
treee68308f64688ca7f5b509c770dce83747daceffe /sys/Makefile.am
parent01877c67b12a10bfb0520469476c592570e9e647 (diff)
Add DirectDraw & DirectSound plugins to the build and docs.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * docs/plugins/gst-plugins-good-plugins.args: * sys/Makefile.am: * win32/MANIFEST: Add DirectDraw & DirectSound plugins to the build and docs.
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index af7d9c96..0076cd57 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -10,6 +10,18 @@ else
OSS_DIR=
endif
+if USE_DIRECTDRAW
+DIRECTDRAW_DIR=directdraw
+else
+DIRECTDRAW_DIR=
+endif
+
+if USE_DIRECTSOUND
+DIRECTSOUND_DIR=directsound
+else
+DIRECTSOUND_DIR=
+endif
+
if USE_SUNAUDIO
SUNAUDIO_DIR=sunaudio
else
@@ -64,6 +76,6 @@ else
XIMAGE_DIR=
endif
-SUBDIRS=$(OSS_DIR) $(OSX_AUDIO_DIR) $(SUNAUDIO_DIR) $(V4L2_DIR) $(XIMAGE_DIR)
+SUBDIRS=$(DIRECTDRAW_DIR) $(DIRECTSOUND_DIR) $(OSS_DIR) $(OSX_AUDIO_DIR) $(SUNAUDIO_DIR) $(V4L2_DIR) $(XIMAGE_DIR)
-DIST_SUBDIRS=oss osxaudio sunaudio v4l2 ximage
+DIST_SUBDIRS=directdraw directsound oss osxaudio sunaudio v4l2 ximage