summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2002-07-27 01:38:32 +0000
committerWim Taymans <wim.taymans@gmail.com>2002-07-27 01:38:32 +0000
commitb5a39eb4c31ca01ff7dc0769f049c14d33b738bc (patch)
tree270d3e29533fc8b9bfbead1eaa56ad46dc91e13e /sys/Makefile.am
parent8e52ce8206b50445e72652b70402c02a03851bbf (diff)
Added conditional for cdrom, someone needs to write a configure check to make this work
Original commit message from CVS: Added conditional for cdrom, someone needs to write a configure check to make this work
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 92b9468d..aefb6481 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -40,8 +40,14 @@ else
XVIDEO_DIR=
endif
+if USE_CDROM
+CDROM_DIR=cdrom
+else
+CDROM_DIR=
+endif
+
SUBDIRS=$(DXR3_DIR) $(OSS_DIR) $(QCAM_DIR) $(V4L_DIR) $(VCD_DIR) \
- $(VGA_DIR) $(XVIDEO_DIR)
+ $(VGA_DIR) $(XVIDEO_DIR) $(CDROM_DIR)
-DIST_SUBDIRS=dxr3 oss qcam v4l vcd vga xvideo videosink
+DIST_SUBDIRS=dxr3 oss qcam v4l vcd vga xvideo videosink cdrom