summaryrefslogtreecommitdiffstats
path: root/sys/directsound/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vtorri@univ-evry.fr>2007-01-04 09:44:57 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-04 09:44:57 +0000
commit40de57f68f561c14609daff2990565b96de8b883 (patch)
treef9a04e2005e716c216e208cd661a2079eed2af52 /sys/directsound/Makefile.am
parent2ae3fda5fa6fc299f43c1371f08ef649080a79de (diff)
Add directsoundsink to build and dist it, so it gets built when compiling with MingW on win32 and the required header...
Original commit message from CVS: Patch by: Vincent Torri <vtorri at univ-evry fr> * configure.ac: * sys/Makefile.am: * sys/directsound/Makefile.am: * sys/directsound/gstdirectsoundsink.c: (gst_directsoundsink_reset): Add directsoundsink to build and dist it, so it gets built when compiling with MingW on win32 and the required headers and libraries are available (fixes: #392638). Also simplify DirectDraw check a bit. * tests/check/elements/.cvsignore: Fix CVS ignore for neonhttpsrc test binary.
Diffstat (limited to 'sys/directsound/Makefile.am')
-rw-r--r--sys/directsound/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys/directsound/Makefile.am b/sys/directsound/Makefile.am
new file mode 100644
index 00000000..b8b26469
--- /dev/null
+++ b/sys/directsound/Makefile.am
@@ -0,0 +1,9 @@
+plugin_LTLIBRARIES = libgstdirectsoundsink.la
+
+libgstdirectsoundsink_la_SOURCES = gstdirectsoundsink.c gstdirectsoundplugin.c
+libgstdirectsoundsink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstdirectsoundsink_la_LIBADD = $(DIRECTSOUND_LIBS) \
+ $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR)
+libgstdirectsoundsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)