summaryrefslogtreecommitdiffstats
path: root/sys/oss/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2003-07-16 16:08:14 +0000
committerAndy Wingo <wingo@pobox.com>2003-07-16 16:08:14 +0000
commit6f06c87c1255c45d0fd020ff30a41b9a7e83a7d9 (patch)
treedecbc26bb22fa79998cee2d5fa15642c250397ae /sys/oss/Makefile.am
parent4418ea96599cdac151f62689269f88055b3d7edf (diff)
actually recurse into sndfile if we are able big ladspa cleanups, mainly to comply with the buffer-frames caps proper...
Original commit message from CVS: * actually recurse into sndfile if we are able * big ladspa cleanups, mainly to comply with the buffer-frames caps property, but also general cleanups - the samplerate prop is gone, if you want to set it explicitly (as in for get-based plugins) you need to use a filtered connection, just like with buffer-frames * big float2int and int2float changes for buffer-frames compatibility - I think it's quite a bit simpler * make the ossclock general, add it to gstaudio, and use it in sndfile as well i need to update mimetypes, but that's coming soon. there are some other plugins that don't support buffer-frames, i guess i need to get around to fixing them as well.
Diffstat (limited to 'sys/oss/Makefile.am')
-rw-r--r--sys/oss/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/sys/oss/Makefile.am b/sys/oss/Makefile.am
index be0a9aba..de370819 100644
--- a/sys/oss/Makefile.am
+++ b/sys/oss/Makefile.am
@@ -8,7 +8,6 @@ libgstossaudio_la_SOURCES = gstosssink.c \
gstosssrc.c \
gstossaudio.c \
gstossgst.c \
- gstossclock.c \
gstosscommon.c
libgstossaudio_la_CFLAGS = $(GST_CFLAGS)
@@ -18,4 +17,4 @@ libgstossaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstosshelper_la_SOURCES = gstosshelper.c
libgstosshelper_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstosssink.h gstosssrc.h gstossgst.h gstossclock.h gstosshelper.h gstosscommon.h
+noinst_HEADERS = gstosssink.h gstosssrc.h gstossgst.h gstosshelper.h gstosscommon.h