summaryrefslogtreecommitdiffstats
path: root/sys/oss/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-09-13 01:22:59 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-09-13 01:22:59 +0000
commit96fc83aeacef995433db8ee4794227d9b3d2ca6b (patch)
treebba38e3589d56522ac6ab4b9edc37d20837f76d2 /sys/oss/Makefile.am
parentadda650f237852748a9f1070b7923f0df194c3d6 (diff)
Interface implementation example: OSS mixer. Also osscommon->osselement so it can be loaded without being a source/si...
Original commit message from CVS: Interface implementation example: OSS mixer. Also osscommon->osselement so it can be loaded without being a source/sink (for a stand-alone mixer)
Diffstat (limited to 'sys/oss/Makefile.am')
-rw-r--r--sys/oss/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys/oss/Makefile.am b/sys/oss/Makefile.am
index 37b0f8fe..21d957b5 100644
--- a/sys/oss/Makefile.am
+++ b/sys/oss/Makefile.am
@@ -3,11 +3,12 @@ plugin_LTLIBRARIES = libgstossaudio.la
EXTRA_LTLIBRARIES = libgstosshelper.la
-libgstossaudio_la_SOURCES = gstosssink.c \
+libgstossaudio_la_SOURCES = gstossaudio.c \
+ gstosselement.c \
+ gstossmixer.c \
+ gstosssink.c \
gstosssrc.c \
- gstossaudio.c \
- gstossgst.c \
- gstosscommon.c
+ gstossgst.c
libgstossaudio_la_CFLAGS = $(GST_CFLAGS)
libgstossaudio_la_LIBADD =
@@ -16,4 +17,9 @@ libgstossaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstosshelper_la_SOURCES = gstosshelper.c
libgstosshelper_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstosssink.h gstosssrc.h gstossgst.h gstosshelper.h gstosscommon.h
+noinst_HEADERS = gstosssink.h \
+ gstosssrc.h \
+ gstossgst.h \
+ gstosshelper.h \
+ gstosselement.h \
+ gstossmixer.c