summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-03-15 11:39:53 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-03-15 11:39:53 +0000
commit4d0df9433c3a9ba3345c4d394b7ec20653ee6044 (patch)
tree075dbaaf00bbc7b14de4a6d87dc7519c4d90bfb9 /sys/osxaudio/Makefile.am
parent1be3219c706bf105acde3efcafe20b962def928d (diff)
Activate osxaudio in gst-plugins-good with proper build setup.
Original commit message from CVS: * configure.ac: * sys/Makefile.am: * sys/osxaudio/Makefile.am: * sys/osxaudio/gstosxaudio.c: * sys/osxaudio/gstosxaudiosink.c: (gst_osx_audio_sink_osxelement_do_init), (gst_osx_audio_sink_init), (gst_osx_audio_sink_getcaps), (gst_osx_audio_sink_create_ringbuffer), (plugin_init): * sys/osxaudio/gstosxaudiosrc.c: (gst_osx_audio_src_osxelement_do_init), (gst_osx_audio_src_init), (gst_osx_audio_src_create_ringbuffer): * sys/osxaudio/gstosxringbuffer.c: (gst_osx_ring_buffer_get_type), (gst_osx_ring_buffer_class_init), (gst_osx_ring_buffer_init), (gst_osx_ring_buffer_acquire), (gst_osx_ring_buffer_start), (gst_osx_ring_buffer_pause), (gst_osx_ring_buffer_stop): * sys/osxaudio/gstosxringbuffer.h: Activate osxaudio in gst-plugins-good with proper build setup. Add inlined documentation. Fix debug statements Fix ringbuffer when pausing. Fixes #323471
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
index 58a19dc1..4ea2114c 100644
--- a/sys/osxaudio/Makefile.am
+++ b/sys/osxaudio/Makefile.am
@@ -5,8 +5,12 @@ libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
gstosxaudiosink.c \
gstosxaudiosrc.c
-libgstosxaudio_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GSTPB_BASE_FLAGS)
-libgstosxaudio_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GSTPB_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@
+libgstosxaudio_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+libgstosxaudio_la_LIBADD = \
+ -lgstinterfaces-@GST_MAJORMINOR@ \
+ -lgstaudio-@GST_MAJORMINOR@ \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_LIBS)
libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio
noinst_HEADERS = gstosxaudiosink.h \