summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-05-20 19:45:13 +0000
committerDavid Schleef <ds@schleef.org>2004-05-20 19:45:13 +0000
commit8552e8fa8b541e1d6bc2228365ac7b5f54633e7d (patch)
tree35fbd73d1c44e68ff87805e818f218721e6a7348 /sys/osxaudio/Makefile.am
parent7e229910559e9c9e136fb09c874cb75ca7461e31 (diff)
sys/osxaudio/Makefile.am: New OS X audio plugin by Zaheer Merali
Original commit message from CVS: * sys/osxaudio/Makefile.am: New OS X audio plugin by Zaheer Merali * sys/osxaudio/gstosxaudio.c: * sys/osxaudio/gstosxaudioelement.c: * sys/osxaudio/gstosxaudioelement.h: * sys/osxaudio/gstosxaudiosink.c: * sys/osxaudio/gstosxaudiosink.h: * sys/osxaudio/gstosxaudiosrc.c: * sys/osxaudio/gstosxaudiosrc.h:
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
new file mode 100644
index 00000000..7d6bcfa7
--- /dev/null
+++ b/sys/osxaudio/Makefile.am
@@ -0,0 +1,17 @@
+plugin_LTLIBRARIES = libgstosxaudio.la
+
+libgstosxaudio_la_SOURCES = gstosxaudio.c \
+ gstosxaudioelement.c \
+ gstosxaudiosink.c \
+ gstosxaudiosrc.c
+
+libgstosxaudio_la_CFLAGS = $(GST_CFLAGS)
+libgstosxaudio_la_LIBADD = $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
+libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -framework CoreAudio
+
+noinst_HEADERS = gstosxaudiosink.h \
+ gstosxaudioelement.h \
+ gstosxaudiosrc.h
+
+
+