summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2006-04-26 16:29:38 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2006-04-26 16:29:38 +0000
commitcb163be477869c77651ccf659080bb74ca595e04 (patch)
tree1df0c0840e902ecce1183b62e425d9c0a33279c6 /sys/osxaudio/Makefile.am
parenta3fca5680bd81ce8880be7fba1d8a8c7955d5f4e (diff)
sys/osxaudio/: Port of osxaudiosink to 0.10
Original commit message from CVS: 2006-04-26 Zaheer Abbas Merali <zaheerabbas at merali dot org> * sys/osxaudio/Makefile.am: * sys/osxaudio/gstosxaudioelement.c: (gst_osx_audio_element_get_type), (gst_osx_audio_element_class_init): * sys/osxaudio/gstosxaudioelement.h: * sys/osxaudio/gstosxaudiosink.c: (gst_osx_audio_sink_osxelement_do_init), (gst_osx_audio_sink_base_init), (gst_osx_audio_sink_class_init), (gst_osx_audio_sink_init), (gst_osx_audio_sink_set_property), (gst_osx_audio_sink_get_property), (gst_osx_audio_sink_getcaps), (gst_osx_audio_sink_create_ringbuffer), (gst_osx_audio_sink_io_proc), (gst_osx_audio_sink_osxelement_init), (plugin_init): * sys/osxaudio/gstosxaudiosink.h: Port of osxaudiosink to 0.10
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
index 0744f450..5f34489f 100644
--- a/sys/osxaudio/Makefile.am
+++ b/sys/osxaudio/Makefile.am
@@ -1,19 +1,16 @@
plugin_LTLIBRARIES = libgstosxaudio.la
-libgstosxaudio_la_SOURCES = gstosxaudio.c \
+libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
gstosxaudioelement.c \
- gstosxaudiosink.c \
- gstosxaudiosrc.c
+ gstosxaudiosink.c
-# FIXME: clean up these linker flags
-libgstosxaudio_la_CFLAGS = $(GST_CFLAGS)
-libgstosxaudio_la_LIBADD = $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la $(GST_LIBS)
-LIBS = -Wl,-framework -Wl,CoreAudio
-libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -framework CoreAudio
+libgstosxaudio_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GSTPB_BASE_FLAGS)
+libgstosxaudio_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GSTPB_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@
+libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio
noinst_HEADERS = gstosxaudiosink.h \
gstosxaudioelement.h \
- gstosxaudiosrc.h
+ gstosxringbuffer.h