summaryrefslogtreecommitdiffstats
path: root/sys/osxvideo/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-01-30 17:19:33 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-01-30 17:19:33 +0000
commit5d004d2c32f4941a2dc8c2b6b4927151d240887a (patch)
tree376193bec4d8a17369f2fce0a12f4712f2e059c6 /sys/osxvideo/Makefile.am
parent10294f3849a452c526cda5ca6e509437a8a3c714 (diff)
configure.ac: Check for an Objective C compiler
Original commit message from CVS: * configure.ac: Check for an Objective C compiler * sys/Makefile.am: * sys/osxvideo/Makefile.am: * sys/osxvideo/cocoawindow.h: * sys/osxvideo/cocoawindow.m: * sys/osxvideo/osxvideosink.h: * sys/osxvideo/osxvideosink.m: Port of osxvideo plugin to 0.10. Do NOT consider 100% stable ! Fixes #402470
Diffstat (limited to 'sys/osxvideo/Makefile.am')
-rw-r--r--sys/osxvideo/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys/osxvideo/Makefile.am b/sys/osxvideo/Makefile.am
new file mode 100644
index 00000000..99bb0489
--- /dev/null
+++ b/sys/osxvideo/Makefile.am
@@ -0,0 +1,17 @@
+# FIXME: clean up this crap
+OBJC=gcc
+
+plugin_LTLIBRARIES = libgstosxvideosink.la
+
+libgstosxvideosink_la_SOURCES = osxvideosink.m cocoawindow.m
+libgstosxvideosink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstosxvideosink_la_LIBADD = \
+ $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ -lgstinterfaces-$(GST_MAJORMINOR)
+
+libgstosxvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,Cocoa -Wl,-framework -Wl,QuickTime -Wl,-framework -Wl,OpenGL
+
+AM_OBJCFLAGS=$(CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS)
+
+noinst_HEADERS = osxvideosink.h cocoawindow.h