summaryrefslogtreecommitdiffstats
path: root/sys/sunaudio/Makefile.am
diff options
context:
space:
mode:
authorChristian Schaller <uraeus@gnome.org>2006-01-09 17:04:52 +0000
committerChristian Schaller <uraeus@gnome.org>2006-01-09 17:04:52 +0000
commit9b94e38300ef023c12e66aa4df0efa1a8911a92c (patch)
tree49f69768275d034faf5c6cb318b55dd34034771f /sys/sunaudio/Makefile.am
parent8189a4da729d4df81a9143887948e35193ccf13a (diff)
add Sun Audio plugin. Verified that nothing breaks and that make check works.
Original commit message from CVS: add Sun Audio plugin. Verified that nothing breaks and that make check works. Don't think the docs gets properly built yet, but I don't understand exactly how to enable that.
Diffstat (limited to 'sys/sunaudio/Makefile.am')
-rw-r--r--sys/sunaudio/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys/sunaudio/Makefile.am b/sys/sunaudio/Makefile.am
new file mode 100644
index 00000000..95e5f9e8
--- /dev/null
+++ b/sys/sunaudio/Makefile.am
@@ -0,0 +1,21 @@
+plugin_LTLIBRARIES = libgstsunaudio.la
+
+libgstsunaudio_la_SOURCES = gstsunaudio.c \
+ gstsunaudiosink.c \
+ gstsunaudiomixerctrl.c \
+ gstsunaudiomixer.c \
+ gstsunaudiomixertrack.c
+
+libgstsunaudio_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+libgstsunaudio_la_LIBADD = \
+ -lgstinterfaces-@GST_MAJORMINOR@ \
+ -lgstaudio-@GST_MAJORMINOR@ \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_LIBS)
+libgstsunaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstsunaudiosink.h \
+ gstsunaudiomixer.h \
+ gstsunaudiomixerctrl.h \
+ gstsunaudiomixertrack.h
+