summaryrefslogtreecommitdiffstats
path: root/sys/v4l2/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-03-02 21:58:52 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-03-02 21:58:52 +0000
commit1a8a2ef6e402a703234fb19c976476eda1e16c75 (patch)
tree0ccc6de66daecb21c6a561bafe66c38cfb6bba3a /sys/v4l2/Makefile.am
parentfd90de31133882bfc20105293e4da837b9e83717 (diff)
Unification of the way to speak to v4l2 and v4l elements... Also fix a segfautl when doing gst-inspect v4l2src
Original commit message from CVS: Unification of the way to speak to v4l2 and v4l elements... Also fix a segfautl when doing gst-inspect v4l2src
Diffstat (limited to 'sys/v4l2/Makefile.am')
-rw-r--r--sys/v4l2/Makefile.am32
1 files changed, 30 insertions, 2 deletions
diff --git a/sys/v4l2/Makefile.am b/sys/v4l2/Makefile.am
index 976e7305..84da9a9d 100644
--- a/sys/v4l2/Makefile.am
+++ b/sys/v4l2/Makefile.am
@@ -4,7 +4,7 @@ plugin_LTLIBRARIES = \
libgstv4l2element.la \
libgstv4l2src.la
-libgstv4l2element_la_SOURCES = gstv4l2element.c v4l2_calls.c v4l2-overlay_calls.c
+libgstv4l2element_la_SOURCES = gstv4l2element.c v4l2_calls.c v4l2-overlay_calls.c gstv4l2element-marshal.c
libgstv4l2element_la_CFLAGS = $(GST_CFLAGS)
libgstv4l2element_la_LIBADD =
libgstv4l2element_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
@@ -15,4 +15,32 @@ libgstv4l2src_la_LIBADD = libgstv4l2element.la
libgstv4l2src_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstv4l2element.h v4l2_calls.h \
- gstv4l2src.h v4l2src_calls.h
+ gstv4l2src.h v4l2src_calls.h gstv4l2element-marshal.h
+
+EXTRA_libgstv4l2element_la_SOURCES = \
+ gstv4l2element-marshal.list
+
+BUILT_SOURCES = \
+ gstv4l2element-marshal.c \
+ gstv4l2element-marshal.h
+
+gstv4l2element-marshal.h: gstv4l2element-marshal.list
+ glib-genmarshal --header --prefix=gstv4l2_cclosure_marshal $(srcdir)/gstv4l2element-marshal.list > gstv4l2element-marshal.h.tmp
+ mv gstv4l2element-marshal.h.tmp gstv4l2element-marshal.h
+
+gstv4l2element-marshal.c: gstv4l2element-marshal.list
+ echo "#include \"glib.h\"" > gstv4l2element-marshal.c.tmp
+ echo "#include \"glib-object.h\"" >> gstv4l2element-marshal.c.tmp
+ echo "#include \"gstv4l2element-marshal.h\"" >> gstv4l2element-marshal.c.tmp
+ glib-genmarshal --body --prefix=gstv4l2_cclosure_marshal $(srcdir)/gstv4l2element-marshal.list >> gstv4l2element-marshal.c.tmp
+ mv gstv4l2element-marshal.c.tmp gstv4l2element-marshal.c
+
+# Don't want the generated marshal files in the dist
+dist-hook:
+ rm -f $(distdir)/gstv4l2element-marshal.c
+ rm -f $(distdir)/gstv4l2element-marshal.h
+
+# Clean generated files
+distclean-local:
+ rm -f $(top_builddir)/src/element/gstv4l2element-marshal.c
+ rm -f $(top_builddir)/src/element/gstv4l2element-marshal.h