summaryrefslogtreecommitdiffstats
path: root/sys/v4l2/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2002-09-09 07:14:35 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2002-09-09 07:14:35 +0000
commit9413402bc62412071704d4bf1e1f3b88242fdc6e (patch)
treec146303857bec6ed2ce23963a9b705c4395af634 /sys/v4l2/Makefile.am
parent7d260c0d41d966ebc142c2de5c269f87dd8b7e3a (diff)
this adds video4linux2 source and element plugins. The division in v4l2* plugins is the same as for v4l1 - i.e. an el...
Original commit message from CVS: this adds video4linux2 source and element plugins. The division in v4l2* plugins is the same as for v4l1 - i.e. an element, a src and a sink, but there won't be separate encoding plugins (like v4lmjpegsrc) - all functionality is (thanks to video4linux2) integrated in one plugin: v4l2src. v4l2sink is still to be done, that'll come later.
Diffstat (limited to 'sys/v4l2/Makefile.am')
-rw-r--r--sys/v4l2/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys/v4l2/Makefile.am b/sys/v4l2/Makefile.am
new file mode 100644
index 00000000..18fe742a
--- /dev/null
+++ b/sys/v4l2/Makefile.am
@@ -0,0 +1,18 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = \
+ libgstv4l2element.la \
+ libgstv4l2src.la
+
+libgstv4l2element_la_SOURCES = gstv4l2element.c v4l2_calls.c v4l2-overlay_calls.c
+libgstv4l2element_la_CFLAGS = $(GST_CFLAGS)
+libgstv4l2element_la_LIBADD =
+libgstv4l2element_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+libgstv4l2src_la_SOURCES = gstv4l2src.c v4l2src_calls.c
+libgstv4l2src_la_CFLAGS = $(GST_CFLAGS)
+libgstv4l2src_la_LIBADD = libgstv4l2element.la
+libgstv4l2src_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstv4l2element.h v4l2_calls.h \
+ gstv4l2src.h v4l2src_calls.h