summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-05-01 11:46:33 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-05-01 11:46:33 +0000
commit8d58b030d62888b25efa032fb7dba368730704b0 (patch)
tree300f444b9e9210ab3ccf2ef40d4447f0c7b2ade4 /tests/check/Makefile.am
parenta4ddb7b60a7a0750de0b80a47d6cbe1b41b71f3a (diff)
docs/plugins/Makefile.am: also check .cc files for gtk-doc markup
Original commit message from CVS: * docs/plugins/Makefile.am: also check .cc files for gtk-doc markup * configure.ac: * docs/plugins/gst-plugins-good-plugins-docs.sgml: * docs/plugins/gst-plugins-good-plugins-sections.txt: * tests/check/Makefile.am: * tests/check/elements/id3v2mux.c: (id3v2mux_suite), (main): * ext/Makefile.am: * ext/taglib/Makefile.am: * ext/taglib/gstid3v2mux.h: * ext/taglib/gsttaglibmux.c: * ext/taglib/gsttaglibmux.h: move taglib-based id3v2muxer to -good. Fixes #336110.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 39e386c9..d0d433b4 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -15,7 +15,11 @@ CLEANFILES = core.* test-registry.xml
clean-local: clean-local-check
-TESTS = $(check_PROGRAMS)
+if USE_TAGLIB
+check_taglib = elements/id3v2mux
+else
+check_taglib =
+endif
check_PROGRAMS = \
elements/avimux \
@@ -25,9 +29,10 @@ check_PROGRAMS = \
elements/cmmlenc \
elements/icydemux
+TESTS = $(check_PROGRAMS)
# these tests don't even pass
-noinst_PROGRAMS =
+noinst_PROGRAMS = $(check_taglib)
AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)