summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-03-10 12:35:44 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-03-10 12:35:44 +0000
commitc98b59c7b855ce61c7eb085714fbbdc6dcdfe6f8 (patch)
treed80deabf9cb0d5faf8a0e5ee58312d17c0e9a072 /tools/Makefile.am
parentfdf6d4edf512dc94a1d745e1e7981257bf293daa (diff)
updating tools generation
Original commit message from CVS: updating tools generation
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am37
1 files changed, 33 insertions, 4 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9f102b07..fcd1f58f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,10 +1,39 @@
-bin_SCRIPTS = gst-launch-ext gst-visualise
+bin_SCRIPTS = \
+ gst-launch-ext-@GST_MAJORMINOR@ \
+ gst-visualise-@GST_MAJORMINOR@
-man_MANS = gst-launch-ext.1 gst-visualise.1
+man_MANS = \
+ gst-launch-ext-@GST_MAJORMINOR@.1 \
+ gst-visualise-@GST_MAJORMINOR@.1
-all: all-am chmod
+CLEANFILES = $(man_MANS)
+
+EXTRA_DIST = \
+ gst-launch-ext-m.m gst-visualise-m.m \
+ gst-launch-ext.in gst-visualise.in
+
+# generate versioned scripts from templates
+%-@GST_MAJORMINOR@: %-m.m
+ sed -e s,\@GST_MAJORMINOR\@,@GST_MAJORMINOR@,g $< > $@
+ chmod +x $@
-EXTRA_DIST = $(bin_SCRIPTS) $(man_MANS) gst-launch-ext.in
+# generate man pages
+%-@GST_MAJORMINOR@.1: %.1.in
+ sed \
+ -e s,gst-complete,gst-complete-@GST_MAJORMINOR@,g \
+ -e s,gst-compprep,gst-compprep-@GST_MAJORMINOR@,g \
+ -e s,gst-feedback,gst-feedback-@GST_MAJORMINOR@,g \
+ -e s,gst-inspect,gst-inspect-@GST_MAJORMINOR@,g \
+ -e s,gst-launch,gst-launch-@GST_MAJORMINOR@,g \
+ -e s,gst-launch-ext,gst-launch-ext-@GST_MAJORMINOR@,g \
+ -e s,gst-md5sum,gst-md5sum-@GST_MAJORMINOR@,g \
+ -e s,gst-register,gst-register-@GST_MAJORMINOR@,g \
+ -e s,gst-typefind,gst-typefind-@GST_MAJORMINOR@,g \
+ -e s,gst-visualise,gst-visualise-@GST_MAJORMINOR@,g \
+ -e s,gst-xmllaunch,gst-xmllaunch-@GST_MAJORMINOR@,g \
+ $< >$@
+
+all: all-am chmod
chmod: $(bin_SCRIPTS)
chmod +x $^