summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c637fa8e..ae6c7670 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,11 @@
-SUBDIRS=gst-libs gst sys ext examples tools ## testsuite
+if HAVE_GCONF
+GCONF_DIR=gconf
+else
+GCONF_DIR=
+endif
-DIST_SUBDIRS=gst-libs gst sys ext examples tools ## testsuite
+SUBDIRS=gst-libs gst sys ext examples tools $(GCONF_DIR) ## testsuite
+
+DIST_SUBDIRS=gst-libs gst sys ext examples tools gconf ## testsuite
EXTRA_DIST=gst-plugins.spec depcomp AUTHORS COPYING README RELEASE ChangeLog autogen.sh