summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ff27cbe..06fdfc38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,18 +6,26 @@ else
GCONF_DIR =
endif
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
+
ALWAYS_SUBDIRS = \
gst sys ext \
- check docs \
+ docs \
po \
m4 common
SUBDIRS = \
$(ALWAYS_SUBDIRS) \
+ $(SUBDIRS_CHECK) \
$(GCONF_DIR)
DIST_SUBDIRS = \
$(ALWAYS_SUBDIRS) \
+ check \
gconf
EXTRA_DIST = \