summaryrefslogtreecommitdiffstats
path: root/check/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'check/Makefile.am')
-rw-r--r--check/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/check/Makefile.am b/check/Makefile.am
deleted file mode 100644
index 256c19a0..00000000
--- a/check/Makefile.am
+++ /dev/null
@@ -1,34 +0,0 @@
-include $(top_srcdir)/common/check.mak
-
-CHECK_REGISTRY = $(top_builddir)/check/test-registry.xml
-
-REGISTRY_ENVIRONMENT = \
- GST_REGISTRY=$(CHECK_REGISTRY)
-
-TESTS_ENVIRONMENT = \
- $(REGISTRY_ENVIRONMENT) \
- GST_PLUGIN_SYSTEM_PATH= \
- GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/ext:$(GST_PLUGINS_DIR)
-
-# ths core dumps of some machines have PIDs appended
-CLEANFILES = core.* test-registry.xml
-
-clean-local: clean-local-check
-
-TESTS = $(check_PROGRAMS)
-
-check_PROGRAMS = \
- elements/level \
- elements/matroskamux
-
-
-# these tests don't even pass
-noinst_PROGRAMS =
-
-AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
-LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
-
-# valgrind testing
-VALGRIND_TESTS_DISABLE =
-
-SUPPRESSIONS = $(top_srcdir)/common/gst.supp