summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e82a38b..a8af0ae6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,20 @@ AM_PROG_CC_STDC
AM_PROG_AS
AS="${CC}"
+dnl the gettext stuff needed
+AM_GNU_GETTEXT_VERSION(0.11.4)
+AM_GNU_GETTEXT([external])
+
+GETTEXT_PACKAGE=gst-plugins-$GST_MAJORMINOR
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "$GETTEXT_PACKAGE",
+ [gettext package name])
+
+dnl define LOCALEDIR in config.h
+AS_AC_EXPAND(LOCALEDIR, $datadir/locale)
+AC_DEFINE_UNQUOTED([LOCALEDIR], "$LOCALEDIR",
+ [gettext locale dir])
+
dnl decide on error flags
AS_COMPILER_FLAG(-Wall, GST_WALL="yes", GST_WALL="no")
@@ -1695,6 +1709,7 @@ tools/Makefile
tools/gst-launch-ext
gconf/Makefile
pkgconfig/Makefile
+po/Makefile.in
)
AC_OUTPUT