summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac177
1 files changed, 14 insertions, 163 deletions
diff --git a/configure.ac b/configure.ac
index fbd61624..30115173 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,12 +12,13 @@ AM_MAINTAINER_MODE
dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too
-AS_VERSION(gst-plugins, GST_PLUGINS_VERSION, 0, 9, 0, 1, GST_CVS="no", GST_CVS="yes")
+AS_VERSION(gst-plugins-good, GST_PLUGINS_GOOD_VERSION, 0, 9, 0, 1,
+ GST_CVS="no", GST_CVS="yes")
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
dnl our libraries and install dirs use major.minor as a version
-GST_MAJORMINOR=$GST_PLUGINS_VERSION_MAJOR.$GST_PLUGINS_VERSION_MINOR
+GST_MAJORMINOR=$GST_PLUGINS_GOOD_VERSION_MAJOR.$GST_PLUGINS_GOOD_VERSION_MINOR
dnl we override it here if we need to for the release candidate of new series
GST_MAJORMINOR=0.9
AC_SUBST(GST_MAJORMINOR)
@@ -28,7 +29,7 @@ dnl - interfaces added/removed/changed -> increment CURRENT, REVISION = 0
dnl - interfaces added -> increment AGE
dnl - interfaces removed -> AGE = 0
dnl for 0.8.3 release, gst_play_get_all_by_interface was added, so update
-AS_LIBTOOL(GST_PLUGINS, 1, 0, 1)
+AS_LIBTOOL(GST_PLUGINS_GOOD, 0, 0, 0)
AS_LIBTOOL_TAGS([CXX])
AM_PROG_LIBTOOL
@@ -51,7 +52,7 @@ dnl the gettext stuff needed
AM_GNU_GETTEXT_VERSION(0.11.5)
AM_GNU_GETTEXT([external])
-GETTEXT_PACKAGE=gst-plugins-$GST_MAJORMINOR
+GETTEXT_PACKAGE=gst-plugins-good-$GST_MAJORMINOR
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "$GETTEXT_PACKAGE",
[gettext package name])
@@ -92,12 +93,6 @@ AC_CHECK_HEADER(malloc.h,[
dnl Check for a way to display the function name in debug output
GST_CHECK_FUNCTION()
-dnl define correct errorlevel for debugging messages. We want to have GST_ERROR
-dnl messages printed when running cvs builds
-if test "x$GST_CVS" = "xyes"; then
- AC_DEFINE(GST_LEVEL_DEFAULT, GST_LEVEL_ERROR, [Default errorlevel to use])
-fi
-
dnl Check for FIONREAD ioctl declaration :
GST_CHECK_FIONREAD()
@@ -143,27 +138,6 @@ GST_CHECK_FEATURE(EXTERNAL, [enable building of plug-ins with external deps],,
# make BUILD_EXTERNAL available to Makefile.am
AM_CONDITIONAL(BUILD_EXTERNAL, test "x$BUILD_EXTERNAL" = "xyes")
-dnl experimental plug-ins; stuff that hasn't had the dust settle yet
-dnl read 'builds, but might not work'UTO
-GST_CHECK_FEATURE(EXPERIMENTAL, [enable building of experimental plug-ins],,
-[HAVE_EXPERIMENTAL=yes],disabled,
-[
- AC_MSG_WARN(building experimental plug-ins)
- USE_TARKIN="yes"
-],[
- AC_MSG_NOTICE(not building experimental plug-ins)
- USE_TARKIN="no"
-])
-
-dnl broken plug-ins; stuff that doesn't seem to build at the moment
-GST_CHECK_FEATURE(BROKEN, [enable building of broken plug-ins],,
-HAVE_BROKEN=yes,disabled,
-[
- AC_MSG_WARN([building broken plug-ins -- no bug reports on these, only patches :)])
-],[
- AC_MSG_NOTICE([not building broken plug-ins])
-])
-
dnl ##############################
dnl # Do automated configuration #
dnl ##############################
@@ -284,6 +258,7 @@ GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '[_]*(gst_|Gst|
AC_SUBST(GST_PLUGIN_LDFLAGS)
dnl these are all the gst plug-ins, compilable without additional libs
+dnl videofilter is at the top because others depend on it
GST_PLUGINS_ALL="\
videofilter \
alpha \
@@ -294,27 +269,15 @@ GST_PLUGINS_ALL="\
goom \
law \
level \
- mpegaudioparse \
- qtdemux \
- realmedia \
rtp \
rtsp \
smpte \
- silence \
udp \
videobox \
wavenc \
wavparse \
- mpegaudioparse \
"
-dnl see if we can build C++ plug-ins
-if test "x$HAVE_CXX" = "xyes"; then
- GST_PLUGINS_ALL="$GST_PLUGINS_ALL"
-else
- AC_MSG_WARN([Not compiling plug-ins requiring C++ compiler])
-fi
-
AC_SUBST(GST_PLUGINS_ALL)
GST_PLUGINS_SELECTED=""
@@ -370,16 +333,6 @@ GST_CHECK_FEATURE(AALIB, [aasink plug-in], aasink, [
AS_SCRUB_INCLUDE(AALIB_CFLAGS)
])
-dnl *** AMR-NB ***
-translit(dnm, m, l) AM_CONDITIONAL(USE_AMRNB, true)
-GST_CHECK_FEATURE(AMRNB, [AMR-NB], amrnbdec amrnbenc, [
- GST_CHECK_LIBHEADER(AMRNB, amrnb,
- Decoder_Interface_init, -lm,
- amrnb/interf_dec.h,
- AMRNB_LIBS="-lamrnb -lm"
- AC_SUBST(AMRNB_LIBS))
-])
-
dnl **** ESound ****
translit(dnm, m, l) AM_CONDITIONAL(USE_ESD, true)
GST_CHECK_FEATURE(ESD, [esound plug-ins], esdsink, [
@@ -393,39 +346,6 @@ GST_CHECK_FEATURE(ESD, [esound plug-ins], esdsink, [
])
])
-dnl **** Free AAC Decoder (FAAD) ****
-translit(dnm, m, l) AM_CONDITIONAL(USE_FAAD, true)
-GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
- HAVE_FAAD="yes"
- GST_CHECK_LIBHEADER(FAAD, faad, faacDecOpen, -lm, faad.h, FAAD_LIBS="-lfaad -lm", HAVE_FAAD="no")
- if test $HAVE_FAAD = "yes"; then
- AC_MSG_CHECKING([Checking for FAAD >= 2])
- AC_TRY_RUN([
-
-#include <faad.h>
-#if !defined(FAAD2_VERSION) || !defined(FAAD_FMT_DOUBLE)
-#error Not faad2
-#else
-#include <string.h>
-
-int main()
-{
-char version[9] = FAAD2_VERSION;
-// a release candidate of 2.0 is not enought for us
-if ( strstr( version, "2.0 RC" ) ) { return 1; }
-
-return 0;
-}
-
-#endif
- ],
- [ HAVE_FAAD="yes" && AC_MSG_RESULT(yes)],
- [ HAVE_FAAD="no" && AC_MSG_RESULT(no)])
- fi;
- AS_SCRUB_INCLUDE(FAAD_CFLAGS)
- AC_SUBST(FAAD_LIBS)
-])
-
dnl *** FLAC ***
translit(dnm, m, l) AM_CONDITIONAL(USE_FLAC, true)
GST_CHECK_FEATURE(FLAC, [FLAC lossless audio], flacenc flacdec, [
@@ -467,31 +387,6 @@ GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
AC_CHECK_HEADER(ladspa.h, HAVE_LADSPA="yes", HAVE_LADSPA="no")
])
-dnl *** lame ***
-translit(dnm, m, l) AM_CONDITIONAL(USE_LAME, true)
-GST_CHECK_FEATURE(LAME, [lame mp3 encoder library], lame, [
- GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h,
- [
- HAVE_LAME="yes"
- LAME_LIBS="-lmp3lame -lm"
- dnl is lame presets available
- LAME_CFLAGS=""
- AC_TRY_RUN([
-#include <lame/lame.h>
-int main (int argc, char *argv[])
-{
- printf("%d\n", MEDIUM);
- return 0;
-}
- ],
- [LAME_CFLAGS="-DGSTLAME_PRESET"],
- [LAME_CFLAGS=""]
- )
- AC_SUBST(LAME_CFLAGS)
- AC_SUBST(LAME_LIBS)
- ])
-])
-
dnl *** libcaca ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LIBCACA, true)
GST_CHECK_FEATURE(LIBCACA, [libcaca], libcaca, [
@@ -516,35 +411,6 @@ GST_CHECK_FEATURE(LIBPNG, [libpng PNG encoder], pngenc, [
AC_SUBST(LIBPNG_LIBS)
])
-dnl *** mad ***
-dnl FIXME: we could use header checks here as well IMO
-translit(dnm, m, l) AM_CONDITIONAL(USE_MAD, true)
-GST_CHECK_FEATURE(MAD, [mad mp3 decoder], mad, [
- dnl check with pkg-config first
- PKG_CHECK_MODULES(MAD, mad >= 0.15 id3tag >= 0.15, HAVE_MAD="yes", HAVE_MAD="no")
- if test "x$HAVE_MAD" = "xno"; then
- dnl fall back to oldskool detection
- AC_CHECK_LIB(mad, mad_decoder_finish, HAVE_MAD="yes" MAD_LIBS="-lmad")
- if test "x$HAVE_MAD" = "xyes"; then
- HAVE_MAD="no"
- save_LIBS=$LIBS
- LIBS="-lz"
- AC_CHECK_LIB(id3tag, id3_tag_options, HAVE_MAD="yes" MAD_LIBS="-lmad -lid3tag -lz")
- LIBS=$save_LIBS
- fi
- fi
-])
-AC_SUBST(MAD_LIBS)
-
-dnl *** mpeg2dec ***
-translit(dnm, m, l) AM_CONDITIONAL(USE_MPEG2DEC, true)
-GST_CHECK_FEATURE(MPEG2DEC, [mpeg2dec], mpeg2dec, [
- PKG_CHECK_MODULES(MPEG2DEC, libmpeg2 >= 0.4.0,
- HAVE_MPEG2DEC="yes", HAVE_MPEG2DEC="no")
- AC_SUBST(MPEG2DEC_CFLAGS)
- AC_SUBST(MPEG2DEC_LIBS)
-])
-
dnl *** dv1394 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DV1394, true)
GST_CHECK_FEATURE(DV1394, [raw1394 and avc1394 library], dv1394src, [
@@ -585,12 +451,6 @@ GST_CHECK_FEATURE(SHOUT2, [shout2 plug-in], shout2send, [
])
])
-dnl *** sidplay : works with libsidplay 1.36.x (not 2.x.x) ***
-translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
-GST_CHECK_FEATURE(SIDPLAY, [sidplay plug-in], sidplay, [
- GST_PATH_SIDPLAY()
-])
-
dnl *** speex >= 1.0.4 or >= 1.1.5 ***
dnl 1.1.4 and earlier were not API/ABI compatible with 1.0
dnl 1.1.6 is the first to use a .pc/pkg-config file ***
@@ -687,9 +547,9 @@ dnl #########################
dnl # Make the output files #
dnl #########################
+dnl keep this alphabetic per directory, please
AC_CONFIG_FILES(
Makefile
-gst-plugins.spec
gst/Makefile
gst/alpha/Makefile
gst/autodetect/Makefile
@@ -699,45 +559,36 @@ gst/fdsrc/Makefile
gst/goom/Makefile
gst/law/Makefile
gst/level/Makefile
-gst/mpegaudioparse/Makefile
-gst/realmedia/Makefile
gst/rtp/Makefile
gst/rtsp/Makefile
gst/smpte/Makefile
-gst/silence/Makefile
gst/udp/Makefile
gst/videobox/Makefile
gst/videofilter/Makefile
-ext/jpeg/Makefile
-gst/qtdemux/Makefile
gst/wavenc/Makefile
gst/wavparse/Makefile
-gst-libs/Makefile
-gst-libs/gst/Makefile
-sys/Makefile
-sys/oss/Makefile
+ext/jpeg/Makefile
ext/Makefile
ext/aalib/Makefile
ext/dv/Makefile
+ext/esd/Makefile
ext/flac/Makefile
ext/gconf/Makefile
ext/ladspa/Makefile
-ext/lame/Makefile
ext/libcaca/Makefile
ext/libpng/Makefile
-ext/mad/Makefile
ext/raw1394/Makefile
ext/shout2/Makefile
-ext/sidplay/Makefile
ext/speex/Makefile
-ext/esd/Makefile
-ext/mpeg2dec/Makefile
-ext/faad/Makefile
-ext/amrnb/Makefile
+sys/Makefile
+sys/oss/Makefile
po/Makefile.in
common/Makefile
common/m4/Makefile
+gconf/Makefile
+gconf/gstreamer.schemas
m4/Makefile
+gst-plugins-good.spec
)
AC_OUTPUT