summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ddb17be2..da521426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -904,6 +904,14 @@ AG_GST_CHECK_FEATURE(TAGLIB, [taglib tagging library], taglib, [
if test "x$HAVE_CXX" != "xyes"; then
USE_TAGLIB=false
AC_MSG_NOTICE([Not building taglib plugin: no C++ compiler found])
+ else
+ dnl work around bug in taglib 1.5 headers, remove once there is a 1.6
+ AS_CXX_COMPILER_FLAG([-Wno-attributes], [
+ TAGLIB_CXXFLAGS="$TAGLIB_CFLAGS -Wno-attributes"
+ ], [
+ TAGLIB_CXXFLAGS="$TAGLIB_CFLAGS"
+ ])
+ AC_SUBST(TAGLIB_CXXFLAGS)
fi
])