summaryrefslogtreecommitdiffstats
path: root/sys/directsound/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/directsound/Makefile.am')
-rw-r--r--sys/directsound/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys/directsound/Makefile.am b/sys/directsound/Makefile.am
index b8b26469..3b24de62 100644
--- a/sys/directsound/Makefile.am
+++ b/sys/directsound/Makefile.am
@@ -2,8 +2,8 @@ plugin_LTLIBRARIES = libgstdirectsoundsink.la
libgstdirectsoundsink_la_SOURCES = gstdirectsoundsink.c gstdirectsoundplugin.c
libgstdirectsoundsink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS)
+ $(GST_PLUGINS_BASE_CFLAGS) $(DIRECTSOUND_CFLAGS)
libgstdirectsoundsink_la_LIBADD = $(DIRECTSOUND_LIBS) \
$(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
-lgstaudio-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR)
-libgstdirectsoundsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstdirectsoundsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTSOUND_LDFLAGS)