summaryrefslogtreecommitdiffstats
path: root/sys/osxaudio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/osxaudio/Makefile.am')
-rw-r--r--sys/osxaudio/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/sys/osxaudio/Makefile.am b/sys/osxaudio/Makefile.am
index d1040648..f8a8ca40 100644
--- a/sys/osxaudio/Makefile.am
+++ b/sys/osxaudio/Makefile.am
@@ -1,25 +1,25 @@
plugin_LTLIBRARIES = libgstosxaudio.la
-libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
- gstosxaudioelement.c \
- gstosxaudiosink.c \
- gstosxaudiosrc.c \
- gstosxaudio.c
+libgstosxaudio_la_SOURCES = gstosxringbuffer.c \
+ gstosxaudioelement.c \
+ gstosxaudiosink.c \
+ gstosxaudiosrc.c \
+ gstosxaudio.c
libgstosxaudio_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
- -Wno-deprecated-declarations
-libgstosxaudio_la_LIBADD = \
- -lgstinterfaces-@GST_MAJORMINOR@ \
- -lgstaudio-@GST_MAJORMINOR@ \
- $(GST_PLUGINS_BASE_LIBS) \
- $(GST_LIBS)
-libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio
+ -Wno-deprecated-declarations
+libgstosxaudio_la_LIBADD = \
+ -lgstinterfaces-@GST_MAJORMINOR@ \
+ -lgstaudio-@GST_MAJORMINOR@ \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_LIBS)
+libgstosxaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,CoreAudio,-framework -Wl,AudioUnit
libgstosxaudio_la_LIBTOOLFLAGS = --tag=disable-static
-noinst_HEADERS = gstosxaudiosink.h \
- gstosxaudioelement.h \
- gstosxringbuffer.h \
- gstosxaudiosrc.h
+noinst_HEADERS = gstosxaudiosink.h \
+ gstosxaudioelement.h \
+ gstosxringbuffer.h \
+ gstosxaudiosrc.h