summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c949e2d6..5f10e8f3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,5 @@
if HAVE_GST_CHECK
-SUBDIRS_CHECK = check
+SUBDIRS_CHECK = check files
else
SUBDIRS_CHECK =
endif
@@ -10,7 +10,13 @@ else
SUBDIRS_ICLES =
endif
-SUBDIRS = $(SUBDIRS_CHECK) $(SUBDIRS_ICLES) examples files
+if BUILD_EXAMPLES
+SUBDIR_EXAMPLES = examples
+else
+SUBDIR_EXAMPLES =
+endif
+
+SUBDIRS = $(SUBDIRS_CHECK) $(SUBDIRS_ICLES) $(SUBDIR_EXAMPLES)
DIST_SUBDIRS = check icles examples files