summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
new file mode 100644
index 00000000..115216a0
--- /dev/null
+++ b/tests/check/Makefile.am
@@ -0,0 +1,38 @@
+include $(top_srcdir)/common/check.mak
+
+CHECK_REGISTRY = $(top_builddir)/check/test-registry.xml
+
+REGISTRY_ENVIRONMENT = \
+ GST_REGISTRY=$(CHECK_REGISTRY)
+
+TESTS_ENVIRONMENT = \
+ $(REGISTRY_ENVIRONMENT) \
+ GST_PLUGIN_PATH_ONLY=yes \
+ GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/ext:$(GST_PLUGINS_DIR)
+
+# ths core dumps of some machines have PIDs appended
+CLEANFILES = core.* test-registry.xml
+
+clean-local: clean-local-check
+
+$(CHECK_REGISTRY):
+ $(TESTS_ENVIRONMENT) \
+ $(GST_TOOLS_DIR)/gst-register-@GST_MAJORMINOR@
+
+TESTS = $(GST_TOOLS_DIR)/gst-register-@GST_MAJORMINOR@ \
+ $(check_PROGRAMS)
+
+check_PROGRAMS = \
+ elements/level
+
+# these tests don't even pass
+noinst_PROGRAMS =
+
+AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
+LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
+
+# valgrind testing
+VALGRIND_TESTS_DISABLE = \
+ $(GST_TOOLS_DIR)/gst-register-@GST_MAJORMINOR@
+
+SUPPRESSIONS = $(top_srcdir)/common/gst.supp