summaryrefslogtreecommitdiffstats
path: root/tests/examples/audiofx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples/audiofx/Makefile.am')
-rw-r--r--tests/examples/audiofx/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/examples/audiofx/Makefile.am b/tests/examples/audiofx/Makefile.am
new file mode 100644
index 00000000..efcf785b
--- /dev/null
+++ b/tests/examples/audiofx/Makefile.am
@@ -0,0 +1,7 @@
+noinst_PROGRAMS = firfilter-example iirfilter-example
+
+firfilter_example_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+firfilter_example_LDADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstfft-@GST_MAJORMINOR@ $(LIBM)
+
+iirfilter_example_CFLAGS = $(GST_CFLAGS)
+iirfilter_example_LDADD = $(GST_LIBS) $(LIBM)