summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-09-10 13:31:06 +0000
committerLennart Poettering <lennart@poettering.net>2004-09-10 13:31:06 +0000
commitc0b67627b12536efe6bac5a065f1e6b0a5d39c72 (patch)
tree12b9ddde7d468c2dbed85abdc6b3842031811939 /Makefile.am
parent626941c51c739ae7fcfc2cb46e6edc2336b393e7 (diff)
initial commit
git-svn-id: file:///home/lennart/svn/public/gst-pulse/trunk@3 bb39ca4e-bce3-0310-b5d4-eea78a553289
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5ab9c3c
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,42 @@
+# $Id$
+#
+# This file is part of gst-polyp.
+#
+# gst-polyp is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# gst-polyp is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with gst-polyp; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = bootstrap.sh README LICENSE
+SUBDIRS=src
+# doc
+
+MAINTAINERCLEANFILES=README
+noinst_DATA = README
+
+README:
+ rm -f README
+# $(MAKE) -C doc README
+# cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/gst-polyp
+ cp gst-polyp-@PACKAGE_VERSION@.tar.gz $$HOME/homepage/private/projects/gst-polyp
+ cp doc/README.html doc/style.css $$HOME/homepage/private/projects/gst-polyp
+ cp $$HOME/homepage/private/projects/gst-polyp/README.html $$HOME/homepage/private/projects/gst-polyp/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck