summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-09-10 13:31:06 +0000
committerLennart Poettering <lennart@poettering.net>2004-09-10 13:31:06 +0000
commitc0b67627b12536efe6bac5a065f1e6b0a5d39c72 (patch)
tree12b9ddde7d468c2dbed85abdc6b3842031811939 /configure.ac
parent626941c51c739ae7fcfc2cb46e6edc2336b393e7 (diff)
initial commit
git-svn-id: file:///home/lennart/svn/public/gst-pulse/trunk@3 bb39ca4e-bce3-0310-b5d4-eea78a553289
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac90
1 files changed, 90 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c3ebd83
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,90 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+# $Id$
+
+# This file is part of gst-polyp.
+#
+# gst-polyp is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# gst-polyp is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with gst-polyp; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+AC_PREREQ(2.57)
+AC_INIT([gst-polyp],[0.2],[mzkzzfcbylc (at) 0pointer (dot) de])
+AC_CONFIG_SRCDIR([src/plugin.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign -Wall])
+
+AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/gst-polyp/])
+
+if type -p stow > /dev/null && test -d /usr/local/stow ; then
+ AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
+ ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
+fi
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LN_S
+AC_PROG_LIBTOOL
+
+AC_CHECK_FUNCS([gethostname])
+AC_CHECK_HEADERS([limits.h])
+AC_C_CONST
+AC_FUNC_MALLOC
+AC_TYPE_SIZE_T
+
+ACX_PTHREAD
+
+if test -d ../polypaudio ; then
+ POLYP_CFLAGS='-I$(top_srcdir)/../polypaudio'
+ POLYP_LIBS='-L$(top_srcdir)/../polypaudio/polyp -lpolyp -lpolyp-error -lpolyp-mainloop'
+ echo "*** Found polypaudio in ../polypaudio, using that version ***"
+else
+ PKG_CHECK_MODULES(POLYP, [ polyplib >= 0.4 ])
+fi
+
+AC_SUBST(POLYP_LIBS)
+AC_SUBST(POLYP_CFLAGS)
+
+
+PKG_CHECK_MODULES(GST, [ gstreamer-0.8 >= 0.8.4 ])
+
+AC_SUBST(GST_LIBS)
+AC_SUBST(GST_CFLAGS)
+y
+# If using GCC specifiy some additional parameters
+if test "x$GCC" = "xyes" ; then
+ CFLAGS="$CFLAGS -pipe -Wall -W -Wno-unused-parameter"
+fi
+
+# LYNX documentation generation
+AC_ARG_ENABLE(lynx,
+ AS_HELP_STRING(--disable-lynx,Turn off lynx usage for documentation generation),
+[case "${enableval}" in
+ yes) lynx=yes ;;
+ no) lynx=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-lynx) ;;
+esac],[lynx=yes])
+
+if test x$lynx = xyes ; then
+ AC_CHECK_PROG(have_lynx, lynx, yes, no)
+
+ if test x$have_lynx = xno ; then
+ AC_MSG_ERROR([*** Sorry, you have to install lynx or use --disable-lynx ***])
+ fi
+fi
+
+AM_CONDITIONAL([USE_LYNX], [test "x$lynx" = xyes])
+
+AC_CONFIG_FILES([Makefile src/Makefile]) # doc/Makefile doc/README.html])
+AC_OUTPUT