summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-01-15 22:20:14 +0000
committerLennart Poettering <lennart@poettering.net>2005-01-15 22:20:14 +0000
commitad8230c938a46d42fa53e69915c35842936612d2 (patch)
tree21bc9424251b6c7d9669299717fdd3ed66d2dd98 /Makefile.am
parentcee709762ac069885a7066a3d6ae362a4c45656f (diff)
add autoconf stuff
git-svn-id: file:///home/lennart/svn/public/heatload/trunk@9 3bca8330-beed-0310-b360-ea58cfc96e4b
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..574c2fd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+# $Id$
+#
+# This file is part of heatload.
+#
+# heatload is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# heatload is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with heatload; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = bootstrap.sh README LICENSE
+SUBDIRS=src #doc
+
+MAINTAINERCLEANFILES=README
+noinst_DATA = README
+
+README:
+ rm -f README
+ touch README
+# $(MAKE) -C doc README
+# cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist doxygen
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/heatload
+ cp heatload-@PACKAGE_VERSION@.tar.gz doc/README.html doc/style.css $$HOME/homepage/private/projects/heatload
+ ln -sf README.html $$HOME/homepage/private/projects/heatload/index.html
+
+.PHONY: homepage