summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 8523d68..11c8dd1 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -18,13 +18,20 @@
man_MANS = ifmetric.8
-EXTRA_DIST = $(man_MANS) ifmetric.8.xml.in
+noinst_DATA = ifmetric.8.xml
+
+EXTRA_DIST = $(man_MANS) ifmetric.8.xml.in xmltoman.css xmltoman.xsl xmltoman.dtd
+
+CLEANFILES = ifmetric.8.xml
+
+ifmetric.8.xml: ifmetric.8.xml.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' $< > $@
if USE_XMLTOMAN
-CLEANFILES = $(man_MANS)
+CLEANFILES += $(man_MANS)
-ifmetric.8: ifmetric.8.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' $< | xmltoman - > $@
+ifmetric.8: ifmetric.8.xml Makefile
+ xmltoman $< > $@
endif