summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-01-20 00:57:48 +0000
committerLennart Poettering <lennart@poettering.net>2004-01-20 00:57:48 +0000
commitdb47e69e340b2b8e1edd46739416fc8361d26384 (patch)
tree86cab3174ca6ebd537b6e99542af16be04234c67 /configure.ac
parent3438270f9f25c703ffa2491d3d2b98d80032583f (diff)
conditional install of init scripts
git-svn-id: file:///home/lennart/svn/public/ivam2/trunk@54 dbf6933d-3bce-0310-9bcc-ed052ba35b35
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 20 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index a310c3c..5f98ff8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,24 +76,29 @@ AC_SUBST(LIBOOP_LIBS)
# Init script location
AC_ARG_WITH(initdir, AS_HELP_STRING(--with-initdir=DIR,Install init script in DIR (system dependent default)))
-test "x$with_initdir" = xyes -o "x$with_initdir" = xno && with_initdir=
-
-if test "x$with_initdir" = x ; then
- if test -d /etc/init.d ; then
- SYSINITDIR=/etc/init.d
- else
- if test -d /etc/rc.d/init.d ; then
- SYSINITDIR=/etc/rc.d/init.d
- else
- AC_MSG_ERROR([missing --with-initdir=DIR])
- fi
- fi
+if test "x$with_initdir" = xno ; then
+ SYSINITDIR=no
+ AC_MSG_NOTICE([*** No init script will be installed ***])
else
- SYSINITDIR="$with_initdir"
-fi
+ test "x$with_initdir" = xyes && with_initdir=
-AC_MSG_NOTICE([*** Init sript will be installed in $SYSINITDIR ***])
+ if test "x$with_initdir" = x ; then
+ if test -d /etc/init.d ; then
+ SYSINITDIR=/etc/init.d
+ else
+ if test -d /etc/rc.d/init.d ; then
+ SYSINITDIR=/etc/rc.d/init.d
+ else
+ AC_MSG_ERROR([missing --with-initdir=DIR])
+ fi
+ fi
+ else
+ SYSINITDIR="$with_initdir"
+ fi
+ AC_MSG_NOTICE([*** Init script will be installed in $SYSINITDIR ***])
+fi
AC_SUBST(SYSINITDIR)
+AM_CONDITIONAL(NOINITSCRIPT, test x$SYSINITDIR = xno)
# Where to place the spool directory
AC_ARG_WITH(spooldir, AS_HELP_STRING(--with-spooldir=DIR,The $PACKAGE spool directory (/var/spool/$PACKAGE)))