summaryrefslogtreecommitdiffstats
path: root/clients/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
new file mode 100644
index 0000000..5e6e347
--- /dev/null
+++ b/clients/Makefile.am
@@ -0,0 +1,30 @@
+# $Id$
+#
+# This file is part of ivam2.
+#
+# ivam2 is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# ivam2 is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with ivam2; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+bin_SCRIPTS=ivam-autobox ivam-createvb ivam-echo ivam-newmessage ivam-newvoicebox ivam-play ivam-voicebox
+
+STATICSCRIPTS=ivamApi.py ivamCore.py ivamDefs.py ivamPipeConnector.py ivamShbufConnector.py ivamUtil.py ivamVoiceBox.py
+python_PYTHON=$(STATICSCRIPTS) ivamDefs.py
+
+EXTRA_DIST=$(bin_SCRIPTS) $(STATICSCRIPTS)
+CLEANFILES = ivamDefs.py
+
+ivamDefs.py: ivamDefs.py.in Makefile
+ sed -e 's,@SPOOLDIR\@,$(SPOOLDIR),g' \
+ -e 's,@pkgdatadir\@,$(pkgdatadir),g' \
+ -e 's,@bindir\@,$(bindir),g' $< > $@