summaryrefslogtreecommitdiffstats
path: root/conf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'conf/Makefile.am')
-rw-r--r--conf/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/conf/Makefile.am b/conf/Makefile.am
new file mode 100644
index 0000000..e5460ee
--- /dev/null
+++ b/conf/Makefile.am
@@ -0,0 +1,36 @@
+# $Id$
+#
+# This file is part of ivam2.
+#
+# ivam2 is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# ivam2 is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with ivam2; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+pkgsysconfdir=$(sysconfdir)/@PACKAGE@
+sysinitdir=@SYSINITDIR@
+
+pkgsysconf_DATA = msntab ivam2.conf
+
+noinst_DATA = ivam2.init
+EXTRA_DIST = ivam2.init.in $(pkgsysconf_DATA)
+CLEANFILES = ivam2.init
+
+ivam2.init: ivam2.init.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(sysconfdir)/@PACKAGE@,g' -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod 755 $@
+
+install-data-local: ivam2.init
+ $(INSTALL) -b -D -m755 ivam2.init ${DESTDIR}${sysinitdir}/ivam2
+
+uninstall-local:
+ rm -f ${DESTDIR}${sysconfdir}/init.d/ivam2