summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 34fa300..8a8f63f 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,5 @@
# $Id$
-#
+
# This file is part of ivam2.
#
# ivam2 is free software; you can redistribute it and/or modify it
@@ -16,6 +16,21 @@
# along with ivam2; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-pkgdata_DATA = README.VoiceBox
+noinst_DATA = README.html README
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in README.VoiceBox REQUIREMENTS TODO
+
+MAINTAINERCLEANFILES = README README.html
+CLEANFILES =
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html
+ tidy -e < README.html
+
+.PHONY: tidy
-EXTRA_DIST = README README.VoiceBox TODO REQUIREMENTS