summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..9b5b729
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,40 @@
+# $Id$
+#
+# This file is part of ivam2.
+#
+# ivam2 is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# ivam2 is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with ivam2; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+sbin_PROGRAMS = ivamd
+
+ivamd_SOURCES = buffio.c dle.c exec.c main.c modemman.c timevalarith.c cmdline.c dtmffifo.c lock.c modem.c msntab.c util.c \
+ buffio.h dle.h exec.h main.h modemman.h timevalarith.h cmdline.h dtmffifo.h lock.h modem.h msntab.h util.h
+
+ivamd_LDADD = $(LIBOOP_LIBS) $(LIBDAEMON_LIBS)
+ivamd_CFLAGS = $(LIBOOP_CFLAGS) $(LIBDAEMON_CFLAGS) $(AM_CFLAGS) -DPKGSYSCONFDIR="\"${sysconfdir}/@PACKAGE@\"" -DLOCKDIR="\"$(LOCKDIR)\"" -DBINDIR="\"$(bindir)\""
+
+EXTRA_DIST = ivamd.ggo
+MAINTAINERCLEANFILES =
+BUILT_SOURCES =
+CLEANFILES =
+
+if USE_GENGETOPT
+
+CLEANFILES += cmdline.c cmdline.h
+BUILT_SOURCES += cmdline.c cmdline.h
+
+cmdline.c cmdline.h: ivamd.ggo Makefile
+ gengetopt < $<
+
+endif