summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2003-07-27 19:54:27 +0000
committerLennart Poettering <lennart@poettering.net>2003-07-27 19:54:27 +0000
commitce358c24ef7426e8e3013185f60b724fe86faa61 (patch)
tree91127eee0daffe17ee1f45da6628e39014ae9982 /configure.ac
parent14db0c158e42c2f723fef9105551769b6e8436ec (diff)
locking
git-svn-id: file:///home/lennart/svn/public/ivcall/trunk@4 e0b13411-74c3-0310-b366-a0654dd0340f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b6740bc..d2235f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,9 @@ if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
+AC_ARG_WITH(lockdir, AC_HELP_STRING([--with-lockdir=LOCKDIR], [Specify a lock dir]), LOCKDIR="$withval", LOCK_DIR="/var/lock")
+AC_SUBST(LOCK_DIR)
+
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
@@ -93,5 +96,7 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
+AC_MSG_NOTICE([*** Using $LOCK_DIR as lock directory ***])
+
AC_CONFIG_FILES([src/Makefile Makefile man/Makefile doc/Makefile doc/README.html])
AC_OUTPUT